SetLeader Method


Datum Plane Set Leader Method

Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLeader(
	DatumEnds datumEnd,
	View view,
	Leader pLeader
)

Parameters

datumEnd DatumEnds
The end of the datum plane.
view View
The view on which the DatumPlane shows.
pLeader Leader
The Leader for setting the datum plane.
Exceptions
Exception Condition
ArgumentException One of the conditions is not valid: the input leader and view is not null; The leader End, Elbow, Anchor should be in the view; the End of leader should be in the datum plane curves; Elbow is between End and Anchor. -or- The datum plane cannot be visible in the view. -or- The bubble is not visible at the datumEnd of the datum plane.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
The leader can be applied only to ends where the bubble is set to be shown.
See Also