Tests whether the effect instance is appropriate for the given vertex format.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- vertexFormat
- Type: Autodesk.Revit.DB.DirectContext3D VertexFormat
A vertex format.
Return Value
True if the effect instance is valid for use with the specified vertex format.Remarks
The vertex format may define vertex data that are not used by the effect instance. However, the effect instance can not reference vertex data that do not exist in the vertex format.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |