MatchesFormat Method


Effect Instance Matches Format Method

Tests whether the effect instance is appropriate for the given vertex format.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool MatchesFormat(
	VertexFormat vertexFormat
)

Parameters

vertexFormat VertexFormat
A vertex format.

Return Value

Boolean
True if the effect instance is valid for use with the specified vertex format.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The vertex format may define vertex data that are not used by the effect instance. However, the effect instance can not reference vertex data that do not exist in the vertex format.
See Also