This returns true if the intersector is an element that can be used to intersect with the divided path.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- intersector
- Type: Autodesk.Revit.DB ElementId
The intersector.
Return Value
True if the reference can be used to create a divided path, false otherwise.Remarks
Intersectors can be curve elements, datum planes, or other divided paths. Note that divided paths that have this divided path as an intersector (either directly, or recursively) are not valid. Also, if the nesting of divided path intersectors that have intersectors is more than 5 levels deep the divided path intersector is considered invalid as well.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |