MoveNext Method


Increments the iterator to the next workset passing the filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012

Syntax

C#
public virtual bool MoveNext()
Visual Basic
Public Overridable Function MoveNext As Boolean
Visual C++
public:
virtual bool MoveNext()

Return Value

True if there is another available workset passing the filter in this iterator. False if the iterator has completed all available worksets.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException The FilteredWorksetCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also