Sets a cell's style
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- nRow
- Type: System Int32
- nCol
- Type: System Int32
- Style
- Type: Autodesk.Revit.DB TableCellStyle
Remarks
For standard schedule, must set the TableCellStyleOverrideOptions in the TableCellStyle to override this cell. The global base format controls any non-overridden characteristics of this cell.
Examples

public void FormatSubtitle(ViewSchedule colSchedule)
{
TableData colTableData = colSchedule.GetTableData();
TableSectionData tsd = colTableData.GetSectionData(SectionType.Header);
// Subtitle is second row, first column
if (tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber))
{
TableCellStyle tcs = new TableCellStyle();
TableCellStyleOverrideOptions options = new TableCellStyleOverrideOptions();
options.FontSize = true;
options.Bold = true;
tcs.SetCellStyleOverrideOptions(options);
tcs.IsFontBold = true;
tcs.TextSize = 10;
tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs);
}
}

Public Sub FormatSubtitle(colSchedule As ViewSchedule)
Dim colTableData As TableData = colSchedule.GetTableData()
Dim tsd As TableSectionData = colTableData.GetSectionData(SectionType.Header)
' Subtitle is second row, first column
If tsd.AllowOverrideCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber) Then
Dim tcs As New TableCellStyle()
Dim options As New TableCellStyleOverrideOptions()
options.FontSize = True
options.Bold = True
tcs.SetCellStyleOverrideOptions(options)
tcs.IsFontBold = True
tcs.TextSize = 10
tsd.SetCellStyle(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, tcs)
End If
End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- Only allow to override cell style for header section or column header in body section. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |