SetCellStyle Method (Int32, Int32, TableCellStyle)


Table Section Data Set Cell Style(Int 32, Int 32, Table Cell Style) Method

Sets a cell's style

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetCellStyle(
	int nRow,
	int nCol,
	TableCellStyle Style
)

Parameters

nRow Int32
nCol Int32
Style TableCellStyle
Exceptions
Exception Condition
ArgumentException The given row number nRow is invalid. -or- The given column number nCol is invalid. -or- Only allow to override cell style for header section or column header in body section.
ArgumentNullException A non-optional argument was null
Remarks
For standard schedule, must set the TableCellStyleOverrideOptions in the TableCellStyle to override this cell. The global base format controls any non-overridden characteristics of this cell.
See Also