Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- structuralUsage
- Type: Autodesk.Revit.DB.Structure StructuralInstanceUsage
The structural usage to match.
- inverted
- Type: System Boolean
True if the filter should match all family instances which are not of the given structural usage.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |