Structural |
Constructs a new instance of a filter to match family instances by structural usage, with the option to match all family instances which are not of the given structural usage.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public StructuralInstanceUsageFilter(
StructuralInstanceUsage structuralUsage,
bool inverted
)
Parameters
- structuralUsage StructuralInstanceUsage
- The structural usage to match.
- inverted Boolean
- True if the filter should match all family instances which are not of the given structural usage.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |