Returns a list of names of predefined setups of DGN export options.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
A Revit document to retrieve names from.
Return Value
An array of strings representing names of predefined setups.Remarks
To get predefined options in the desired format use the static method getPredefinedOptions defined in DGNExportOptions.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | document is not a project document. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |