Create Method (Document, String)


Creates a new empty fluid type and adds it to the document.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013

Syntax

C#
public static FluidType Create(
	Document document,
	string fluidTypeName
)
Visual Basic
Public Shared Function Create ( _
	document As Document, _
	fluidTypeName As String _
) As FluidType
Visual C++
public:
static FluidType^ Create(
	Document^ document, 
	String^ fluidTypeName
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document.
fluidTypeName
Type: System String
The name of fluid type.

Return Value

The newly created fluid type.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also