Get the string value for an overriden parameter.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- paramId
- Type: Autodesk.Revit.DB ElementId
The id of the parameter
Return Value
The override value of the parameter.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | paramId is not the id of a parameter in the current document, or its value type is not sring. -or- paramId is not a Rebar Container parameter -or- paramId has no override |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |