GetStringOverrideValue Method


Get the string value for an overriden parameter.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public string GetStringOverrideValue(
	ElementId paramId
)
Visual Basic
Public Function GetStringOverrideValue ( _
	paramId As ElementId _
) As String
Visual C++
public:
String^ GetStringOverrideValue(
	ElementId^ paramId
)

Parameters

paramId
Type: Autodesk.Revit.DBElementId
The id of the parameter

Return Value

The override value of the parameter.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException paramId is not the id of a parameter in the current document, or its value type is not sring. -or- paramId is not a Rebar Container parameter -or- paramId has no override
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also