Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- part
- Type: Autodesk.Revit.DB FabricationPart
The part to compare this part with.
- ignoreFields
- Type: System.Collections.Generic IList FabricationPartCompareType
Array of types of data to ignore from the comparison check.
Return Value
Returns true if the fabrication parts are the same.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |