IsSameAs Method


Fabrication Part Is Same As Method

Compare this fabrication part with the part passed and checks the pattern dimensions and options. A list of fields that can be ignored in the comparison check can be specified.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsSameAs(
	FabricationPart part,
	IList<FabricationPartCompareType> ignoreFields
)

Parameters

part FabricationPart
The part to compare this part with.
ignoreFields IList FabricationPartCompareType
Array of types of data to ignore from the comparison check.

Return Value

Boolean
Returns true if the fabrication parts are the same.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also