Creates a new instance of Structural Section Pipe.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- diameter
- Type: System Double
Pipe Diameter.
- wallNominalThickness
- Type: System Double
Represents wall nominal thickness of rectangle.
- wallDesignThickness
- Type: System Double
Represents wall design thickness of rectangle.
- centroidHorizontal
- Type: System Double
Distance from centroid to the left extremites along horizontal axis.
- centroidVertical
- Type: System Double
Distance from centroid to the upper extremites along vertical axis.
- analysisParams
- Type: Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionAnalysisParams
Common set of parameters for structural analysis.