Structural |
Creates a new instance of Structural Section Pipe.
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public StructuralSectionGeneralR(
double diameter,
double wallNominalThickness,
double wallDesignThickness,
double centroidHorizontal,
double centroidVertical,
StructuralSectionAnalysisParams analysisParams
)
Parameters
- diameter Double
- Pipe Diameter.
- wallNominalThickness Double
- Represents wall nominal thickness of rectangle.
- wallDesignThickness Double
- Represents wall design thickness of rectangle.
- centroidHorizontal Double
- Distance from centroid to the left extremites along horizontal axis.
- centroidVertical Double
- Distance from centroid to the upper extremites along vertical axis.
- analysisParams StructuralSectionAnalysisParams
- Common set of parameters for structural analysis.