This class is used by IExternalResourceServers to return KeyBasedTreeEntries data to Revit when their LoadResource method is invoked.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
The class contains a KeyBasedTreeEntries object which should hold the KeyBasedTreeEntries data generated by the IExternalResourceServer.
An ExternalResourceServer can create the KeyBasedTreeEntries from an arbitrary data source by using AddEntry to add individual KeyBasedTreeEntries. Once all the desired entries have been added, BuildEntries can be called to construct the KeyBasedTreeEntries object from the individual entries that were added.
KeyBasedTreeEntriesLoadContent must have a built KeyBasedTreeEntries before its LoadStatus property can be set to ExternalResourceLoadStatus.Success.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceLoadContent
Autodesk.Revit.DB KeyBasedTreeEntriesLoadContent
Autodesk.Revit.DB ExternalResourceLoadContent
Autodesk.Revit.DB KeyBasedTreeEntriesLoadContent