KeyBasedTreeEntriesLoadContent Class


Key Based Tree Entries Load Content Class

This class is used by IExternalResourceServers to return KeyBasedTreeEntries data to Revit when their LoadResource method is invoked.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceLoadContent
Autodesk.Revit.DB KeyBasedTreeEntriesLoadContent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeyBasedTreeEntriesLoadContent : ExternalResourceLoadContent

The KeyBasedTreeEntriesLoadContent type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ExternalResourceLoadContent )
Public property LoadStatus A value to indicate the status of an external resource load operation. IExternalResourceServers should set this in the LoadResource() method.
(Inherited from ExternalResourceLoadContent )
Public property Version The version of the external data that the server is providing in this object.
(Inherited from ExternalResourceLoadContent )
Top
Methods
Name Description
Public method AddEntry Adds one KeyBasedTreeEntry to this KeyBasedTreeEntriesLoadContent, which is used to build a KeyBasedTreeEntries object by BuildEntries function.
Public method BuildEntries Builds a KeyBasedTreeEntries object.
Public method CanAddEntry Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.
Public method Dispose
(Inherited from ExternalResourceLoadContent )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetEntries Gets a copy of KeyBasedTreeEntries object owned by this KeyBasedTreeEntriesLoadContent object.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetLoadResults Returns a copy of the KeyBasedTreeEntriesLoadResults owned by this KeyBasedTreeEntriesLoadContent object.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Static member IsEntriesBuilt Verifies that the KeyBasedTreeEntries object owned by a KeyBasedTreeEntriesLoadContent object is built.
Public method Reset Clears KeyBasedTreeEntriesLoadContent object, including KeyBasedTreeEntries and KeyBasedTreeEntriesLoadResults, owned by this KeyBasedTreeEntriesLoadContent object.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks

The class contains a KeyBasedTreeEntries object which should hold the KeyBasedTreeEntries data generated by the IExternalResourceServer.

An ExternalResourceServer can create the KeyBasedTreeEntries from an arbitrary data source by using AddEntry to add individual KeyBasedTreeEntries. Once all the desired entries have been added, BuildEntries can be called to construct the KeyBasedTreeEntries object from the individual entries that were added.

KeyBasedTreeEntriesLoadContent must have a built KeyBasedTreeEntries before its LoadStatus property can be set to ExternalResourceLoadStatus.Success.

See Also