Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ew
- Type: System Double
East/West offset
- ns
- Type: System Double
North/South offset
- elevation
- Type: System Double
Elevation offset
- angle
- Type: System Double
Rotation from true north, in radians
Remarks
The angle parameter must be in the range of -PI to PI. If the parameter value is outside that range, it will be shifted by 2*PI until it falls into range.