ProjectPosition Constructor


Project Position(Double, Double, Double, Double) Constructor

Construct a new ProjectPosition with the specified East/West offset, North/South offset, elevation offset, and angle of rotation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ProjectPosition(
	double ew,
	double ns,
	double elevation,
	double angle
)

Parameters

ew Double
East/West offset
ns Double
North/South offset
elevation Double
Elevation offset
angle Double
Rotation from true north, in radians
Remarks
The angle parameter must be in the range of -PI to PI. If the parameter value is outside that range, it will be shifted by 2*PI until it falls into range.
See Also