Checks whether new railing can be created and placed on the specified host.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- elementId
- Type: Autodesk.Revit.DB ElementId
The element to check.
Return Value
True if new railing can be created and placed on the host, False otherwise.Remarks
This function will return true for stairs or ramps which can host new railings. Stairs or ramps can host new railings only when they have no associated railing and they are not in editing mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |