IsValidHostForNewRailing Method


Railing Is Valid Host For New Railing Method

Checks whether new railing can be created and placed on the specified host.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidHostForNewRailing(
	Document document,
	ElementId elementId
)

Parameters

document Document
The document.
elementId ElementId
The element to check.

Return Value

Boolean
True if new railing can be created and placed on the host, False otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This function will return true for stairs or ramps which can host new railings. Stairs or ramps can host new railings only when they have no associated railing and they are not in editing mode.
See Also