Sets the spec describing the field's values.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- specTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the spec.
Return Value
The FieldBuilder object may be used to add more details to the field.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The SchemaBuilder has already finished building the Schema. -or- The field type does not utilize unit conversions. |