Sets the spec describing the field's values.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- specTypeId
- Type: Autodesk.Revit.DBForgeTypeId
Identifier of the spec.
Return Value
The FieldBuilder object may be used to add more details to the field.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The SchemaBuilder has already finished building the Schema. -or- The field type does not utilize unit conversions. |