Verifies that the user can be prompted to place the input element type interactively.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementType
- Type: Autodesk.Revit.DB ElementType
The ElementType.
Return Value
True if the user can be prompted to place the input element type interactively, false otherwise.Remarks
If an element type can be placed interactively, it may be used as input to PostRequestForElementTypePlacement(ElementType) to have the user place an instance of the element. However, this function does not evaluate whether that element instance may actually be placed in the current active view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |