UIDocument Can |
Verifies that the user can be prompted to place the input element type interactively.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- elementType ElementType
- The ElementType.
Return Value
BooleanTrue if the user can be prompted to place the input element type interactively, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

If an element type can be placed interactively, it may be used as input to PostRequestForElementTypePlacement(ElementType) to have the user place an instance of the element. However, this function does not evaluate whether that element instance may actually be placed in the current active view.