Validates that the element is from an appropriate document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- element
- Type: Autodesk.Revit.DB Element
The solid to be cut or the cutting solid.
Return Value
True if the element is from an appropriate document for solid-solid cuts, false otherwise.Remarks
Currently an element from either a project document, conceptual model, pattern based curtain panel, or adaptive component family may participate in solid-solid cuts.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |