IsElementFromAppropriateContext Method


Solid Solid Cut Utils Is Element From Appropriate Context Method

Validates that the element is from an appropriate document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsElementFromAppropriateContext(
	Element element
)

Parameters

element Element
The solid to be cut or the cutting solid.

Return Value

Boolean
True if the element is from an appropriate document for solid-solid cuts, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Currently an element from either a project document, conceptual model, pattern based curtain panel, or adaptive component family may participate in solid-solid cuts.
See Also