IsRecommendedTypeForSet Method


Checks if the element type is recommended for alignment labels in sets.

Namespace: Autodesk.Revit.DB.Infrastructure
Assembly: Autodesk.CivilAlignments.DBApplication (in Autodesk.CivilAlignments.DBApplication.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021.1

Syntax

C#
public static bool IsRecommendedTypeForSet(
	Element type
)
Visual Basic
Public Shared Function IsRecommendedTypeForSet ( _
	type As Element _
) As Boolean
Visual C++
public:
static bool IsRecommendedTypeForSet(
	Element^ type
)

Parameters

type
Type: Autodesk.Revit.DB Element
The type element to check.

Remarks

Can be used for finding types to be set to TypeId when creating alignment label sets with CreateSet(Alignment, View, AlignmentStationLabelSetOptions) .

See Also