Gets the number of lines on the specified layer. It also counts the excluded ones.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layer
- Type: Autodesk.Revit.DB.Structure AreaReinforcementLayerType
The layer type for which will return the number of lines.
Return Value
Returns the number of lines on the specified layer.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InapplicableDataException | The layer layer isn't active. |