Creates a new assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document containing the elements.
- assemblyMemberIds
- Type: System.Collections.Generic ICollection ElementId
The elements that comprise the assembly.
- namingCategoryId
- Type: Autodesk.Revit.DB ElementId
The naming category for the assembly instance.
Return Value
The newly created assembly instance.Remarks
Transaction must be committed after calling this method before performing any action on the newly created instance. Assembly type is assigned after the transaction for creating assembly instance is complete.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more element ids was not permitted for membership in the assembly instance. Elements should be of a valid category and should not be a member of an existing assembly. -or- This naming category was not valid for an assembly instance containing the proposed members. The naming category should match one of the member element categories. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |