Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- gridUV
- Type: Autodesk.Revit.DB UV
Coordinates of a point in the rectangular grid of this compound structure.
- splitDirection
- Type: Autodesk.Revit.DB RectangularGridSegmentOrientation
Specifies the direction of the split.
- segmentId1
- Type: System Int32 %
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.
- segmentId2
- Type: System Int32 %
The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.
Return Value
Returns the id of the enclosing region, and -1 if no region encloses the point.Remarks
Grid coordinates correspond to uv coordinates of faces.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | This operation is valid only for vertically compound structures. |