Compound |
Given a pair of grid coordinates, and a direction for splitting, returns the enclosing region and the two segments intersected by a line through the grid point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public int FindEnclosingRegionAndSegments(
UV gridUV,
RectangularGridSegmentOrientation splitDirection,
out int segmentId1,
out int segmentId2
)
Parameters
- gridUV UV
- Coordinates of a point in the rectangular grid of this compound structure.
- splitDirection RectangularGridSegmentOrientation
- Specifies the direction of the split.
- segmentId1 Int32
- The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.
- segmentId2 Int32
- The id of a segment in the boundary of the containing region which is split by a line through gridUV in the specified direction.
Return Value
Int32Returns the id of the enclosing region, and -1 if no region encloses the point.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InvalidOperationException | This operation is valid only for vertically compound structures. |

Grid coordinates correspond to uv coordinates of faces.