Sets the ElementIds for Category elements which are ignored by route calculation.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryIds
- Type: System.Collections.Generic ICollection ElementId
The ids of Categories to be ignored by route calculation.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | One or more ElementIds in categoryIds are not valid Category element ids. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |