SetIgnoredCategoryIds Method


Route Analysis Settings Set Ignored Category Ids Method

Sets the ElementIds for Category elements which are ignored by route calculation.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetIgnoredCategoryIds(
	ICollection<ElementId> categoryIds
)

Parameters

categoryIds ICollection ElementId
The ids of Categories to be ignored by route calculation.
Exceptions
Exception Condition
ArgumentException One or more ElementIds in categoryIds are not valid Category element ids.
ArgumentNullException A non-optional argument was null
See Also