Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document containing the two elements.
- solidToBeCut
- Type: Autodesk.Revit.DB Element
The solid to be cut.
- cuttingSolid
- Type: Autodesk.Revit.DB Element
The cutting solid.
- splitFacesOfCuttingSolid
- Type: System Boolean
True to split faces of cutting solid where it intersects the solid to be cut, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element must be in a project document or in a conceptual model, pattern based curtain panel, or adaptive component family. -or- The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | Failed to add solid-solid cut for the two elements. |