AddCutBetweenSolids Method (Document, Element, Element, Boolean)


Solid Solid Cut Utils Add Cut Between Solids(Document, Element, Element, Boolean) Method

Adds a solid-solid cut for the two elements with the option to control splitting of faces of the cutting solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void AddCutBetweenSolids(
	Document document,
	Element solidToBeCut,
	Element cuttingSolid,
	bool splitFacesOfCuttingSolid
)

Parameters

document Document
The document containing the two elements.
solidToBeCut Element
The solid to be cut.
cuttingSolid Element
The cutting solid.
splitFacesOfCuttingSolid Boolean
True to split faces of cutting solid where it intersects the solid to be cut, false otherwise.
Exceptions
Exception Condition
ArgumentException The element must be in a project document or in a conceptual model, pattern based curtain panel, or adaptive component family. -or- The element does not meet the condition that it must be solid and must be a GenericForm, GeomCombination, or a FamilyInstance.
ArgumentNullException A non-optional argument was null
InvalidOperationException Failed to add solid-solid cut for the two elements.
See Also