Creates a new AppearanceAssetElement from an existing rendering asset.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which to create the AppearanceAssetElement.
- name
- Type: System String
The name of the AppearanceAssetElement.
- asset
- Type: Autodesk.Revit.DB.Visual Asset
The rendering asset of the element.
Return Value
The new AppearanceAssetElement.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name is an empty string. -or- name cannot include prohibited characters. -or- The given value for name is already in use as an appearance asset name. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |