Create Method


Appearance Asset Element Create Method

Creates a new AppearanceAssetElement from an existing rendering asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static AppearanceAssetElement Create(
	Document document,
	string name,
	Asset asset
)

Parameters

document Document
The document in which to create the AppearanceAssetElement.
name String
The name of the AppearanceAssetElement.
asset Asset
The rendering asset of the element.

Return Value

AppearanceAssetElement
The new AppearanceAssetElement.
Exceptions
Exception Condition
ArgumentException name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as an appearance asset name.
ArgumentNullException A non-optional argument was null
See Also