Gets the short display name of the external resource.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The short display name of the external resource.Remarks
For an external resource, such as a Rvt Link loaded from an external server, which has a full display path such as "My Server://Nested/Nested_1.rvt", this function returns "Nested_1.rvt". For an external resource, such as a Rvt Link loaded from the "built-in" server, which has a full display path such as "c:\LocalLinks\Link_1.rvt", this function returns "Link_1.rvt".
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | The ExternalResourceReference (this ExternalResourceReference) is has no valid display path. |