GetResourceShortDisplayName Method


External Resource Reference Get Resource Short Display Name Method

Gets the short display name of the external resource.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetResourceShortDisplayName()

Return Value

String
The short display name of the external resource.
Exceptions
Exception Condition
InvalidOperationException The ExternalResourceReference (this ExternalResourceReference) is has no valid display path.
Remarks
For an external resource, such as a Rvt Link loaded from an external server, which has a full display path such as "My Server://Nested/Nested_1.rvt", this function returns "Nested_1.rvt". For an external resource, such as a Rvt Link loaded from the "built-in" server, which has a full display path such as "c:\LocalLinks\Link_1.rvt", this function returns "Link_1.rvt".
See Also