Removes the externally tagged geometry object by its external ID from this DirectShape.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- externalId
- Type: Autodesk.Revit.DB ExternalGeometryId
The external ID of the externally tagged geometry that should be removed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The externally tagged geometry with the input externalId is not present in this DirectShape. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |