ApplyChange Method


Applies the previously set changes to the selection of fabrication parts to change the size, change the service, or both.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2018.2

Syntax

C#
public FabricationNetworkChangeServiceResult ApplyChange()
Visual Basic
Public Function ApplyChange As FabricationNetworkChangeServiceResult
Visual C++
public:
FabricationNetworkChangeServiceResult ApplyChange()

Remarks

After this method has been invoked, call:

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException The selection contains invalid elements to change.
Autodesk.Revit.Exceptions InvalidOperationException No fabrication configuration is loaded.

See Also