Fabrication |
Applies the previously set changes to the selection of fabrication parts to change the size, change the service, or both.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
FabricationNetworkChangeServiceResult
Exception | Condition |
---|---|
ArgumentException | The selection contains invalid elements to change. |
InvalidOperationException | No fabrication configuration is loaded. |

After this method has been invoked, call:
- GetStraightsThatWereNotChanged to get a set of fabrication part straight element identifiers that were not changed.
- GetElementsThatFailed to get a set of fabrication part element identifiers that had failures.