Creates an array of new detail curve elements.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view in which the detail curves are to be visible.
- geometryCurveArray
- Type: Autodesk.Revit.DB CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.
Return Value
If successful an array of new detail curve elements. Otherwise a null reference ( Nothing in Visual Basic) .Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown when curve is not in plane of the view |