NewDetailCurveArray Method


Item Factory Base New Detail Curve Array Method

Creates an array of new detail curve elements.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DetailCurveArray NewDetailCurveArray(
	View view,
	CurveArray geometryCurveArray
)

Parameters

view View
The view in which the detail curves are to be visible.
geometryCurveArray CurveArray
An array containing the internal geometry curves for detail lines. The curve in array should be bound curve.

Return Value

DetailCurveArray
If successful an array of new detail curve elements. Otherwise .
Exceptions
Exception Condition
ArgumentException Thrown when curve is not in plane of the view
See Also