Checks if the given vertex points are valid for the wire.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- vertexPoints
- Type: System.Collections.Generic IList XYZ
The vertex points.
- startConnector
- Type: Autodesk.Revit.DB Connector
The start connector of the wire.
- endConnector
- Type: Autodesk.Revit.DB Connector
The end connector of the wire.
Return Value
True if the given vertex points are valid, false otherwise.Remarks
X and Y values are compared of the vertices.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |