AreVertexPointsValid Method


Wire Are Vertex Points Valid Method

Checks if the given vertex points are valid for the wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool AreVertexPointsValid(
	IList<XYZ> vertexPoints,
	Connector startConnector,
	Connector endConnector
)

Parameters

vertexPoints IList XYZ
The vertex points.
startConnector Connector
The start connector of the wire.
endConnector Connector
The end connector of the wire.

Return Value

Boolean
True if the given vertex points are valid, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
X and Y values are compared of the vertices.
See Also