Creates a new instance of pipe insulation.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- pipeOrContentElementId
- Type: Autodesk.Revit.DB ElementId
The pipe, fitting, accessory ElementId to which insulation will be added.
- pipeInsulationTypeId
- Type: Autodesk.Revit.DB ElementId
The pipe insulation type. If the input pipe insulation type is InvalidElementId, the default insulation type from the document will be used.
- Thickness
- Type: System Double
The thickness of the insulation.
Return Value
The newly created pipe insulation.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This id does not represent a pipe, fitting, or accessory element. -or- This pipe insulation type is invalid. -or- Thickness is not valid for assignment to insulation or lining elements. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |
Autodesk.Revit.Exceptions InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
Autodesk.Revit.Exceptions ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions ModificationOutsideTransactionException | The document has no open transaction. |